Loomer updates Sequent plugin to v1.4.1 (incl AAX)

Loomer has released version 1.4.1 of Sequent, a modular multi-effects plug-in for Windows, Mac and Linux.

Loomer Sequent

Sequent has seven individual effect blocks: a Beat Looper; two Filters, both switchable between lowpass, bandpass, and highpass modes and capable of self oscillation even without an audio input; an oversampled Distortion unit; a Gate with variable depth and slew; a Panner; and a Delay unit capable of sub millisecond delay times, great for creating everything for from dub, slapback, and bouncing ball style echoes, to metallic comb filters or flanger effects.

Changes in Sequent v1.4.1

  • New: AAX 64-bit Native plug-ins for Windows and Mac OS X.
  • New: Start step can now be set for all sequencers.
  • Improved: Patterns and sequencers can now all have different step lengths.
  • Fixed: Looper module no longer lose pitch modulation settings when swapping between patterns.
  • Fixed: CPU spike which could rarely occur when switching patterns via MIDI.
  • Improved: Various host compatibility fixes.

Sequent (VST/AU/RTAS/AAX/standalone) is available for purchase for £49 GBP (ex VAT).

More information: Loomer / Sequent

Plugin Boutique Sales
D16 Group Repeater delay plugin coming soon